This incident is now resolved. Felix Calls are operating normally with latency at expected levels, and the backlog of queued outbound calls has been fully cleared.
The cause was a data center outage at our upstream GPU infrastructure provider.
Thank you for your patience. If you are still seeing any issues, please contact Fello Support.
Resolved
This incident is now resolved. Felix Calls are operating normally with latency at expected levels, and the backlog of queued outbound calls has been fully cleared.
The cause was a data center outage at our upstream GPU infrastructure provider.
Thank you for your patience. If you are still seeing any issues, please contact Fello Support.
Monitoring
We are seeing consistent signs of recovery across the restored infrastructure, and call latency is back to normal levels.
Outbound calls that were queued during the outage are now being processed. We are working through this backlog gradually and expect it to be fully cleared within the next few hours. During this period, recipients may receive calls that were originally scheduled earlier today.
SMS functionality was unaffected throughout this incident.
We will post a final update once the backlog has cleared and service is fully caught up.
Monitoring
We are gradually routing call traffic back onto the restored infrastructure. Felix Calls are connecting again for most users.
Because traffic is being ramped up progressively, initial calls may see higher-than-normal latency, including slower connection times and some audio delay. We expect this to improve as routing completes and the new capacity warms up.
Identified
Our GPU provider has restored part of the affected capacity. Our team is now working to bring Felix Calls back online on the recovered infrastructure.
Calls may remain unavailable, or connect only intermittently, while we complete this work.
Identified
We have identified the cause of this issue. A data center outage at our upstream GPU infrastructure provider is preventing Felix Calls from connecting. Our provider has been working to restore GPU services for the past couple of hours, and we are in direct contact with them for updates.
In parallel, our engineering team is working to bring a fallback solution online so that call service can be restored independently of the affected data center.
SMS functionality remains unaffected.
Investigating
We are currently investigating an issue that is preventing Felix Calls from connecting. Users may be unable to place or receive calls at this time.
SMS functionality is not affected and continues to operate normally.
Our team is actively working to determine the cause. We will post another update within the next 30 minutes, or sooner if we have new information.